Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2000, 12:33 PM
H. O. Tyler
Guest
 
Posts: n/a
Rough idle on 560 has been a problem ever since I purchased the car last August. I have been in the trouble shooting mode reading the engine manual several times..I had found a bad throttle switch and leaking EHA. Replaced them, but the idle was still rough. This last week I pulled out the injectors and in looking down the holes I saw broken tips on the nozzle holders. I replaced all eight nozzles holders, guides and vacuum hoses on top of the injectors. That fixed it !! The engine has a smooth idle and the acceleration improved considerable. All this for a little over $50.00. The car is 10 years old with 130K miles. All the engine rubber is quite brittle. I think this could be a source of problems for all the old CIS V-8's. Thought I would share this with everyone.

H. O. Tyler
90 560 SEL 130K
85 300 SD 62K
83 240 D 260K
Reply With Quote
  #2  
Old 05-25-2000, 12:57 PM
emmy
Guest
 
Posts: n/a
thanks for the information. might need it someday....

emmy
1991 560SEL 125K
Reply With Quote
  #3  
Old 05-25-2000, 03:34 PM
Registered User
 
Join Date: Jun 1999
Location: MONTREAL, CANADA
Posts: 74
I HAVE A 300SEL 89 AND HAVE A ROUGH IDLE FOR A LONG TIME. THE TECH TOLD ME IT COULD BE THE MIXTURE CONTROL UNIT BUT DUE TO THE COST I DID NOT FIX IT. I DID HAVE MY INJECTORS CHANGED A FEW YEARS BACK. WHAT EXACTLY DID YOU CHANGE THAT CURED THE PROBLEM. APPRECIATE A RESPONSE FROM YOU.
Reply With Quote
  #4  
Old 05-25-2000, 04:01 PM
H. O. Tyler
Guest
 
Posts: n/a
I changed out the fuel injector nozzle holders and rubber vacuum hoses. This is a 560 V-8 gas engine with the CIS fuel injection. The 420 is simular.
Reply With Quote
  #5  
Old 05-27-2000, 09:46 AM
Registered User
 
Join Date: May 2000
Location: Montreal
Posts: 25
Can you please specify the symptoms of the rough idle because my 420 is having problems. It idles smoothe and like every five seconds it gives a jump shake like a piston just fired. Thank you.

Mike
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
240D rough idle - Do I or don't I have rack damper bolt? JohnnyJ Diesel Discussion 8 10-08-2002 09:44 PM
Rough start, rough idle jchip Tech Help 1 10-06-2002 10:12 PM
560 rough ride .... McLaren Tech Help 0 09-20-2002 11:05 PM
280C Rough Idle When Cold ctaylor738 Vintage Mercedes 3 02-06-2002 04:03 PM
ROUGH COLD IDLE PROBLEM SOLVED BENZ-LGB Tech Help 12 05-31-2001 01:50 AM



All times are GMT -4. The time now is 05:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page