Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-10-2003, 07:16 PM
Registered User
Join Date: Sep 2003
Location: Florida
Posts: 24
Air Conditioner/ Heater 300SE 1988

Thank you for staying with me on this! My ignorance is showing!when I used term Computer that is what mechanic told me when it was replaced to the tune of $300.00 +.
Blower is working and can get heat now. You mentioned the bush button panel and I have a feeling that is where the problem is, sometimes it would do nothing for a while when I hchnged them. Like from off to E/C or to A/C or whatever. What should I look for realtive to Temp control and button panel. I will check what you have given me so far.
Thanks Brian
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page