Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-10-2003, 08:54 PM
engnrsrule's Avatar
Registered User
Join Date: Aug 2003
Location: The Big Easy
Posts: 1
Question Stalling at low idle and electric fan

1983 380 SEL - Stalls frequently, but not always when I come to stop, although RPM seems set right (is electronic controlled), 6-700 in P or N and 5-600 in gear.

Problem started on first wet day after I had reconnected a loose 3 conductor canon plug that sits in a bracket between coil and front left headlight. When not connected, engine idles 1-200 RPM faster and does not stall.

Any clue as to what this plug connects to and why being connected causes this problem?

I note emission controls tie to RPM, temperature and oil sensors. Also have not been able to get electrical fan to operate. It works when hot-wired to battery, but never comes on even at high engine temps. fuse is OK. Could this be related to idle problem?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page