Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-14-2003, 12:40 AM
Registered User
 
Join Date: Sep 2001
Location: scottsdale, AZ
Posts: 40
Question BAS ESP Malfunction on 1992 ML 430

Sso I read the manual about the BAS abd the ESP warning light coming on. My ML 430 has about 57,000 miles on it. When i pulled out of the gas station, all of a sudden on dry cement, my front left wheel locked up! Nice experience! I rolled back, and it freed up, but locked up again. the warning light usually goes out when driving, but sometimes stays on a while. Got any ideas? thanks for your help! mike
__________________
mmaeser
Reply With Quote
  #2  
Old 10-14-2003, 09:08 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Bet the ML430 is a 1999 or later, you need to have traction computer scanned with MB scan tool & then see what codes are causing the light to stay on.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 10-14-2003, 09:35 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
$10.00 says its either a brake light switch or a membrane travel sensor. (and in rare occassions a booster switch)




Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #4  
Old 10-14-2003, 11:17 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Sounds pretty weird to me, almost like the ESP control unit (which receives all the wheel speed signals) thinks that the left front wheel is spinning faster than the other 3 and applying the brakes? It's the only thing that makes sense, or maybe a bad valve in the ESP hydraulic unit.

Gilly
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page