Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-06-2000, 12:14 AM
roas
Guest
 
Posts: n/a
Hello All,

We had the "Check Engine" light come on last month on our 96' C280 with 79k on it. We took it in to a Mercedes independent in our area and had it looked at. Well it turned out to be an Oxygen Sensor, the mechanic showed us the junction between the wiring and the sensor body and there appeared to be a tear between the protective layer of material, so we had it replaced. He also had his exhaust measuring equipment hooked up and operating.

The problem is, about 20 miles after the replacement, after shutting down the engine, you get a strong sulfer-ish smell from the exhaust pipe. Not sure if this is related, but the gas mileage has never seemed great in this car with mostly highway cruising(haven't calculated mileage yet, as the car is not driven often).

Anybody have any suggestions and thoughts?

Ross


------------------
96 C280
Reply With Quote
  #2  
Old 06-06-2000, 02:28 AM
unkl300d's Avatar
Registered User
 
Join Date: Jul 1999
Location: San Francisco, Ca
Posts: 2,267
It's normal. Look it up in the archive for
a tech answer. Mine does it and other
posts indicate it as normal.
p.s. Benzmac recommends to keep an eye on the wiring harness
at the thermostat. A general point of
problems for these cars.
cheers.

------------------
1979 300D
133K miles
1989 300SE
1995 C280
Reply With Quote
  #3  
Old 06-06-2000, 10:52 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If the O2 sensor did fail, it will take a while for the adaptation to calibrate the fuel mixture again...The shop should have reset this after making repairs, but if not, it will reset after a while.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #4  
Old 06-08-2000, 01:57 AM
roas
Guest
 
Posts: n/a
Thanks Donnie,

The weekend is coming up fast, guess its time for a long nice drive to the coast to put some miles away.

If any C280 owners are out thier with high mileage numbers, I would be intersted in seeing some numbers? I saw a 98' last week(I think, had the sport body kit) and the car already had a grill badge awarded?

Thanks,
Ross

------------------
96 C280
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intake, Exhaust Manifold available -300d cali model adamb Diesel Discussion 2 10-12-2003 10:23 PM
Noisy 300E Exhaust Bud Tech Help 5 07-24-2002 10:29 PM
Exhaust system for 107 model kctme SL Forum 5 06-17-2002 12:00 AM
Exhaust Problems on C280 troydewan Performance Paddock 0 12-10-2000 10:48 PM
How to locate and exhaust manifold/pipe leak? JRBrown Tech Help 2 05-23-2000 06:54 PM



All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page