Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-29-2003, 04:01 PM
Registered User
Join Date: Apr 2002
Location: San Jose, Costa Rica.
Posts: 50
Angry 1987 300e Trouble Starting.

I have an intermitent problem with my car, sometimes, when I try to start the car, It won't turn, I get ignition on the dash and I can hear the fuel pump running, and I get power on all accesories.
Sometimes It will start after I let it cool down, but today i had to have it towed from the gas station where it died last night. Up until yesterday it was a intermitent problem sometimes weeks would pass without any problems, and sometimes it would do it several times a day.
It is a automatic, could the neutral safety switch be acting up?
or maybe the starter?
I will apreciate any comments or input on this matter.
I also just changed the fuel distributor and fuel injectors, could someone at the BOSCH shop done anything by accident that causes this problem?
Thank you
Reply With Quote
Old 10-29-2003, 05:40 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
It could be a lot of things...

but, you can test the neutral safety switch (NSS) by moving the gear to neutral and see if it starts. If it does, it is a bad NSS.
Among the most common problems, it could be a bad, or going bad, fuel pump relay, you can bridge contacts (do a search), or a bad ignition switch. You can wiggle the ignition and see if it starts.
Happy hunting!
'86 300E
Reply With Quote
Old 10-30-2003, 01:39 PM
csnow's Avatar
Registered User
Join Date: May 2002
Location: Mass
Posts: 1,127
When you say "won't turn", I assume you mean no response at all from the starter, meaning no click or anything.

After the NSS, I would start with the electrical connections running to the starter and the battery cables/battery ground. The starter draws more current than the accessories, and a marginal connection may only be evident under load.

Could also be the ignition switch.
1986 300E 5-Speed 240k mi.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page