Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-15-2003, 12:54 PM
Registered User
Join Date: Nov 2002
Location: Maynard, MA
Posts: 73
broken hood release cable on 1970 280SE

The cable snapped--can you help me get in?


Reply With Quote
Old 11-15-2003, 01:16 PM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Where did it snap, latch end or lever end?
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote
Old 11-15-2003, 02:06 PM
Registered User
Join Date: Nov 2002
Location: Maynard, MA
Posts: 73
So, it didn't snap! I'm not sure what happened, but I think it might have slipped through the adhusting nut.

Anyway, you can pop the latch if you go in from the left side through the grill with a long thin screwdriver.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page