Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2003, 06:33 AM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
flasher puzzle

Maybe someone can help solve the puzzle.

My 72 450SL has a seperate flasher relay (behind the dash) from the hazard switch (on the shifter console). This sole flasher relay is used for right and left signaling as well as hazard flashing.

Left and right signaling works but the hazard does not. I took apart the hazard switch (looks good), cleaned it and reasembled and still does not work. I took apart the flasher and it's OK of course (if it wasn't OK I wouldn't have gotten left and right signaling).

With the flasher relay unplugged and ignition on I have 12V at terminal 49 (turn signal flasher input). But when the hazard switch is depressed I get 0v.

Is this enough info to determine if I have a bad switch ($69) or wire shorted?
__________________
1972 450SL
1982 300D Turbo
Reply With Quote
  #2  
Old 11-26-2003, 05:11 PM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
I'm posting this because I feel I should always conclude my request for help with the solution even if it risks making me look dumb. Who knopws maybe this will help someone with an older MB.

After pouring over the crummy scanned schematic from my 107 shop CD I located the problem. I was not getting any power to pin 30 at the hazard push button module. Pin 30 should always be hot even with the ignition off since it's for the hazards. Turns out that the #1 fuse although visually OK was not making good contact in the holder. Cleaned it up and it's fine now. Pin 15 (from #12 fuse) gets power to the flasher system with the ignition switch on and this allowed the left/right flashers to work.

If the flasher relay works for turn signaling and doesn't work for the hazard it seems kind of obvious that the flasher relay is not the culprit.

I always check my fuses first but did not take the time to remove and clean them this time. I'll never forget this one.

Only consolation is that I know the blinker/hazard system real well now even with a barely readeable schematic.
__________________
1972 450SL
1982 300D Turbo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page