PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   starting question 1994 C280 (http://www.peachparts.com/shopforum/tech-help/79875-starting-question-1994-c280.html)

dwcasey 11-17-2003 05:40 PM

starting question 1994 C280
 
I have a 1994 C280 with about 160k miles. Started having starting problems back in the Spring. I've replace OVP and Fuel Relay in the trunk (green cube).

I've recently been running the Chevron treatment through that I've read here in the forums.

Sometimes it starts fine, sometimes it doesn't...what I notice is that when I turn the key all the way (just before starting) and wait a couple of seconds, I hear a whurr in the back...guess that's the fuel pump?

Then I crank it. If it doesn't start, I'll turn the key all the back, then turn all the way right to listen for the whurr before cranking, but I don't hear the whurr this time and it still doesn't start.

Now I've got the key turned all the way to the right, starter is working overtime and I have to occastionaly pump the gas pedal.

If this is wiring harness related, is there a point along the harness that causes these sorts of problems? In other words, could I just go to that spot and "patch" it?

If it's not the wiring harness...any ideas???


All times are GMT -4. The time now is 04:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website