PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   84, 190E gas, runs rich (http://www.peachparts.com/shopforum/tech-help/79937-84-190e-gas-runs-rich.html)

Phil M 11-18-2003 01:20 PM

84, 190E gas, runs rich
 
Just got done rebuilding my 84 190E. Starts and runs very rich. where to look? O2 sensor? Lambda system? Bought car with seized engine, don't have prior history. Also purchased with with dash partly apart. Climate control, and stero out. Could lack of these components not being connected have an effect on the ECU? I am also not 100% sure of vacuum line configuration. From bottom of manifold, large line to charcoal canister T. Second line from manifold to thermal valve (red), from thermal valve T'd to distributor, and charcoal can. diagrams I have show diffirent configuartions and components.

mike65 11-18-2003 01:57 PM

Sound like it just needs the fuel/air mixture setting correctly which any decent local garage can do (assuming they have an exhaust gas analyiser thingy) I'm no expert but its proberly good idea to get all the bits connected first.

Mike.

2300com 11-18-2003 07:09 PM

I think I would start with the Oxygen sensor or one of the pressure sensors. Both of these are referred to in the Haynes manual when it is runnning rich.

Also, have you tried an injector cleaner? May help.


All times are GMT -4. The time now is 07:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website