Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-22-2003, 10:07 AM
Registered User
 
Join Date: Mar 2003
Location: Cleveland-Akron Ohio
Posts: 150
W210 Suspension Noise

My '98 E320 with 71K miles has developed a very slight clunking noise that appears to originate from the front passenger wheel area. I only hear the noise at low speeds, less than 50mph. I hear the noise repeatedly over uneven roads. Over average bumpy roads I don't notice anything unusual.

Ball joints were replaced at about 50K miles.

Are there any items on the W210 that typically wear at this mileage that could couse this noise?

Thanks.
__________________
Dave

1998 E320
2001 SLK320
2000 Lexus RX300
Reply With Quote
  #2  
Old 11-22-2003, 01:47 PM
resqguy
Guest
 
Posts: n/a
Could be your shocks. Mine were making a clunking sound right before a massive fluid leak.
Reply With Quote
  #3  
Old 11-22-2003, 07:47 PM
Registered User
 
Join Date: Mar 2003
Location: Cleveland-Akron Ohio
Posts: 150
I thought Mercedes shocks were to last near 100K miles under average use? Or, is it typical to replace them at around 70K miles?
__________________
Dave

1998 E320
2001 SLK320
2000 Lexus RX300
Reply With Quote
  #4  
Old 11-23-2003, 07:56 PM
Registered User
 
Join Date: May 1999
Location: Philadelphia, PA USA
Posts: 272
It's your lower control arm bushings

Believe me.. It's your lower control arm bushings.. I am replacing mine right now as we speak.. Do a search on lower control arm bushings... Maybe we can compare notes...

Peter
__________________
Peter L. House
1998 Sport E430
Azure Blue
110,000k Miles

1987 Oldsmobile Cutlass Salon
V8 Bucket Seats
Factory Moon Roof
Reply With Quote
  #5  
Old 12-03-2003, 12:11 PM
Registered User
 
Join Date: Mar 2003
Location: Cleveland-Akron Ohio
Posts: 150
To follow up on my original posting, I had my '98 E320 checked by my mechanic for suspension noise this morning. The cause is loose ball joints, primarily the passenger side.

I was very surprised because they were already replaced while under warranty at just under 50K miles. According to my mechanic, this is a very common item for replacement on all W210s.

I'll have them replaced next week, but I'm really disappointed that this already requires replacement. In the past I've driven cars that include Ford, Chevy, Toyota and Honda to 75K-100K miles and never had the ball joints replaced. Maybe ball joint replacement is something common for late model cars of all marquees. Or, maybe it's just another example of Mercedes' quality, but I won't start that rant on this thread.
__________________
Dave

1998 E320
2001 SLK320
2000 Lexus RX300
Reply With Quote
  #6  
Old 10-12-2004, 01:10 PM
Registered User
 
Join Date: Jan 2000
Posts: 140
I just have my 99 E430 Sport 75k miles repaired for the front end suspension noise. The problem had probably started at around 68k miles. The dealer replaced both sway bars links, right front ball joint and peformed alignment. There is no more clunking noise from the front. Also the steering wheel is tighter or less play.
Reply With Quote
  #7  
Old 10-12-2004, 05:47 PM
Registered User
 
Join Date: Mar 2003
Location: Cleveland-Akron Ohio
Posts: 150
I should have followed up on my last posting regarding the suspension noise. I went to another mechanic and he immediatley diagnosed the problem as bad sway bar links. He replaced the the sway bar and links and the clunking noise was gone. Sure glad I didn't listen to the first mechanic and paid for new ball joints only to find the problem was still there.
__________________
Dave

1998 E320
2001 SLK320
2000 Lexus RX300
Reply With Quote
  #8  
Old 10-12-2004, 10:11 PM
Registered User
 
Join Date: Jan 2000
Posts: 140
I really didn't care if the dealer replaced the whole front end suspension because I bought the MB extended warranty. The dealer did replace both front ball joints. Also the right tie rod has been replaced too.
Reply With Quote
  #9  
Old 10-13-2004, 11:51 AM
Registered User
 
Join Date: May 1999
Location: Philadelphia, PA USA
Posts: 272
I had replaced the ball joints during my diagnoses of the problem. Then I realized that it was the end links... Well at least I have new ball joints and lower control arm bushing one less thing to have to worry about..
__________________
Peter L. House
1998 Sport E430
Azure Blue
110,000k Miles

1987 Oldsmobile Cutlass Salon
V8 Bucket Seats
Factory Moon Roof
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page