Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-05-2003, 04:25 AM
mlg mlg is offline
Registered User
Join Date: Dec 2003
Location: tn
Posts: 23
500e repairs

i am a proud owner of a 92 500e i love driving this car i hope to keep it a long time wouldn't mind being buried in it with rolling stones blasting and my seat warmer on hi!
car has 160k miles and is my daily driver i have logged 85k since i bought it 5 yrs ago. i service it regularly with a reputable benz mechanic.
i have 2 problems

1 about a month ago i developed a low pitched rattle/hum heard and felt coming from engine area only while car is in motion with lite application of power with tach at 3000 to 3400 rpm. simultaneously, i noticed a smell of burning oil coming from engine bay after driving the car and a small pool of oil, dime to half dollar size, under the engine on drivers side in morning after driving the car. i'm guessing it's the drivers side valve cover gasket leaking???
if so, i'd consider tackling the repair myself. how long does it take? i'd need detailed instructions and part numbers for all parts so i could order them from PARTSSHOP.

2 about 2 months ago i noticed that the engine will not rev past 4k rpm in 2nd gear until engine is pretty warm. this is taking longer and longer to reach the warm up temp as ambient temps are now in the 20-40 degree range. this same thing happened to me 2 years ago. my mechanic told me that he found a sensor that is mounted to the transmission case to be damaged as if by road derbis. he said this sensor is designed to protect the transmission and will not allow aggressive driving until it senses tha t the transmission fluid has warmed up. he said the sensor was "just hanging on". he repaired it with some epoxy and the problem vanished until just recently. Where is the sensor, can i replace it easily, and what is it called and what is the part number. ?

thank you for your help.
Reply With Quote
Old 12-05-2003, 07:56 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
The sensor sounds like the over pressure sensor. It is located just behind the bell housing on the drivers side. It is the first thing down that side and measures the pressure at the band servo. It causes the timing to be retarded to relieve the force.

If it was patched I would definitely replace it.

As to the leak and hum, I would check your PS fluid as the pump is on the left front of the motor and the fluid looks a lot like engine oil.

For some reason most of the oil leaks we have fixed have been on the passenger side. If you are low on PS fluid it will moan and groan.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 12-05-2003, 11:08 PM
mlg mlg is offline
Registered User
Join Date: Dec 2003
Location: tn
Posts: 23
oops, after removing the intake penum i found the oil leak!!! it's coming from the passenger side valve cover gasket a t the end closest to the radiator. also, broke the shroud that covers the ? distributor (has a central wire and 4 spark plug wires exiting to the spark plugs) it is a black plastic shroud about the size of your fist. it has 2 rectangular holes tha t align with pins on the engine to affix it. what is the trick to move the pegs out of the way so shroud can be removed . i broke the plastic around the upper hole on the passenger
side. i noticed this same peice was broken on the drivers side shroud. now i need to replace both shrouds part numbrrs please.
also please advise on how to replace passenger side valve cover gasket. i'll need parts numbers for all needed parts and instructions how long should the jog take so i can set aside appropriate amount of weekend?
thanx alot mlg
Reply With Quote
Old 12-06-2003, 12:13 AM
Registered User
Join Date: Jan 2001
Location: oregon
Posts: 2,013
Parts numbers may help on some odd items but with regular wear parts if you call Phil with your needs at FastLane he will fix you up. I could not keep my three MB's going out here in the boonies with out FastLane.I thought that maybe owning a Euro model would be a problem but after many many orders only one part had to be returned and that was my fault......

William Rogers.........
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page