Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-05-2003, 02:57 PM
Registered User
Join Date: Dec 2003
Posts: 1
Air conditioning fuse blows when brakes are applied

When stopping quickly, the fuse for the AC blower fails. I have looked for any bare or pinched wires but found none. The fuse only blows when decelerating quickly; does not blow from pressing the brake pedal.

Very strange. Please Help. I have been living with this problem for over a year, and countless fuses.

1984 300SD
Reply With Quote
Old 12-06-2003, 12:31 AM
nhodges's Avatar
Registered User
Join Date: Nov 2001
Location: Northern VA
Posts: 461

Check the plugs at the blower. You obviously have a short somewhere.
N. Hodges
1994 S350
1987 300 SDL (for sale)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page