Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-06-2003, 11:56 PM
Posts: n/a
190E Transmission

I have a noise in automatic transmission when warms up when you come to a stop and shift into neutral or park. It makes a clucking sound. They tell me it's the reverse clutch piston seal. If you shift it back to reverse and then into park or neutral it goes away. Do you know if this is detrimental to the internal parts of the transmission? I am trying to decide if I should have the tranny removed and repaired or not. If it not hurting the tranny I think I would just let it be. Any help or response would be appreciated. Thanks!!
Reply With Quote
Old 12-07-2003, 01:26 AM
Registered User
Join Date: Jul 2000
Posts: 23
did you check the flex disc ? they clunk when worn.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page