Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-27-2000, 11:43 AM
Posts: n/a
Engine idle rough when stopped at stop light/sign and still in "Drive", when accelerating it smooths out to normal but stopped and <5mph it runs extremely rough. Engine was just rebuilt, are there any adjustments I missed to help smooth out this rough idle problem. Any suggestions/tips would be greatly appreciated. Thanks, Rick.

Car - 1993 190E 2.3
Reply With Quote
Old 06-27-2000, 01:04 PM
Zoonhollis's Avatar
Diesel Fanatic
Join Date: Jun 2000
Location: Cary, NC
Posts: 551
First thing I would look for is the engine mounts. If the engine is rebuilt, are the engine mounts new, and/or properly tightened?

Reply With Quote
Old 06-27-2000, 02:14 PM
Posts: n/a
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Zoonhollis:
First thing I would look for is the engine mounts. If the engine is rebuilt, are the engine mounts new, and/or properly tightened?


Clarifying; by rebuilt I mean top end, valve job, head gasket replaced. Engine mounts are good and rough idle was not present prior to top end rebuild.
Reply With Quote
Old 06-27-2000, 06:04 PM
Posts: n/a
Had a problem like that on my car. It was attribute to dirty gas...Perhaps dump some injector cleaner in there! Good Luck
Reply With Quote
Old 06-27-2000, 07:38 PM
Posts: n/a
Try to isolate whether it is an ignition problem or fuel problem. Are the spark wires relatively new. If they are the originals, the metal connectors can go bad and give a rough idle but the ignition will provide enough spark to go through them at higher rpm. You could pull a plug and see if you can tell which one is discolored. Sometimes you get a bad one or it gets a cracked insulator on installation. If one is darker than the others replace it and see if that corrects the problem. If not check the spark wires with an ohm meter. You should have continuity with resistance of about 2K ohms or less.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
240D "nailing" & rough idle TedG Tech Help 0 07-28-2004 12:44 PM
my low, rough idle, stall, hot /start solution: E320/300 rvenerac Tech Help 3 11-20-2003 09:59 AM
Idle very rough when cold Hurshi Tech Help 2 02-10-2003 01:21 PM

All times are GMT -4. The time now is 02:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page