Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2000, 11:44 AM
RayE320
Guest
 
Posts: n/a
Sporadically, my 96 E320 won't crank. The warning lights light and everything else seems fine but no starter. I took it to the dealer and they "deleted numerous codes" which resulted in the car starting fine for three days but this morning again -- no crank. I finally got it started by trying at 15 minute intervals and cycling the key numerous times. After I got it started, the odometer/trip odometer and the digital read out for temperature and clock were of different intensities (the temp and clock readouts were substantially brighter). Its at the dealer again. Any thoughts?
Reply With Quote
  #2  
Old 06-27-2000, 08:21 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
This is a somewhat common problem w/W210 cars. Most common failure is the ignition switch, Have replaced several on this model.
Reply With Quote
  #3  
Old 06-28-2000, 10:17 AM
RayE320
Guest
 
Posts: n/a
Thanks for the help. You were right on the money, the dealer is replacing the switch as we speak. They also tell me they need to replace the alternator and rebulb the instrument cluster. Make sense to you? Thanks again.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Starter Installation - W126 / OM603 300SDL ccooper Tech Help 2 09-29-2004 08:46 PM
Another bad starter? How can that be? MadMerecedes Diesel Discussion 25 04-24-2004 06:18 PM
Interesting starter problem S-Class Guru Tech Help 1 02-14-2003 03:24 PM
Kablam !! Big bang. Cracked valve cover Anon-E-Mouse Diesel Discussion 49 07-27-2002 05:01 PM
'79 300SD W116 starter replacement '79 Super Turtle Diesel Discussion 0 12-10-2001 09:37 PM



All times are GMT -4. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page