Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-12-2003, 02:10 PM
Registered User
Join Date: Dec 2003
Location: Eastern Oregon
Posts: 1
Slow windsheild wiper 95'-124

Receintly purchased a 95 E 300. The single windsheild wiper worked fine till yesterdays rainstorm. Runs very slow at all speed settings. I assume the motor is not burned out or it would not run at all. Of course I could be wrong. How difficult a job to replace the motor if that what it is. Thanks for your help.
Reply With Quote
Old 12-12-2003, 03:27 PM
dtf dtf is offline
Registered User
Join Date: Jul 2003
Location: South East CT
Posts: 793
Have it lubricated first. That could be all it needs.
1994 E320 Wagon (Died @ 308,669 miles)
1995 E300 Diesel (194,000)
1999 E300 Turbodiesel (244,000 miles, dies at 255,000)
2006 Toyota Tundra SR5 AC 4X4 (115,000 miles)
2011 Audi A4 Avant (129,000 miles) hate this car!
BMW 330 xi 6 speed manual (100,034 miles)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page