Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-17-2003, 09:49 AM
Registered User
Join Date: Oct 2003
Location: Sunny South
Posts: 75
replaced no start. not benz

my other car an 850 volvo which i had to take the fuel rack and injectors out because i had to work on the pcv tube.

after putting in the injectors and reattaching the all the vac lines the car has trouble starting. the car has high miles. maybe there's no compression? could i have lost the compression by taking out the injectors?

are there any tricks to get this thing working again? is it safe pull the plugs and put gas in there to try to start it? do you guys have any suggestions i could try?

help! thanks in advance
$500 1982 240d owner "Gunter"
125k miles,4 speed manual
crank windows, MB Tex, all original
no a/c, daily driver
Scorecard so far....
$230 Maaco paint job
$27 dimmer switch, $40 shutoff valve, $45 brake MC, $260 calipers, $40 brake hoses, $40 side fender trim, $20 balancing, $109 lifetime alignment, $10 fuel return lines, $115 oil&fuel filters for next 30k miles
Reply With Quote
Old 12-17-2003, 11:52 AM
Registered User
Join Date: Aug 2002
Posts: 179
right board

I would suggest that you post this question at a volvo site. One I have used in the past with good success is: .

Give it a try. Question may have already been answered.

Reply With Quote
Old 12-17-2003, 11:55 AM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Check the wires -- Volvo wiring is notorious for brittle insulation when it ages, and its entirely possible that the insulation broke off the injector wires under the covers, causing shorts. No juice to the injector, no start.

Also, did you replace the seals? Volvo injector seals are bad about leaking, so if you R&Rd the injectors and didn't put new seals in, you have a nasy vac leak. Replace seals should fix.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 12-17-2003, 01:07 PM
Registered User
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
To add to the other posts, injectors install at the intake ports - not the cylinder head - so could in no way affect compression.

'91 MB 190E 2.3
'08 RAV4 Ltd 3.5
'83 Lazy Daze m'home 5.7
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page