Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-30-2003, 01:40 PM
Registered User
 
Join Date: Dec 2003
Location: Palm Springs, CA
Posts: 759
Question Barely runs at idle.

I have an '87 300E that has brought our excellent mechanic to his knees. The car acts like it is either fuel starved or off timing under 1000 rpm. After we get it over 1000 rpm it runs like a Formula One racer. It has new plugs, wires, rotor, and cap. The fuel distributor has been cleaned. There is a new O2 sensor. We have tried new fuel pumps and a flywheel sensor. There is no engine light or any other warning lights. Where do we go next, the MB Dealer?
Reply With Quote
  #2  
Old 12-30-2003, 03:18 PM
Registered User
 
Join Date: Oct 2002
Location: Colorado Springs
Posts: 481
You need to go through the diagnostics of the fuel system to rule it out. Check your eha numbers and your duty cycle. Do a search there is a lot on this.
m
__________________
Martin Ingram
Colorado Springs
2005 320 CDI
2006.5 VW Jetta TDI
1991 560SEL (179000 Sold)
1972 280SEL 4.5 ('The Lead Sled' 320000 miles when sold.)
1972 220D (225000 when sold)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page