Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-06-2000, 08:22 PM
Posts: n/a
the starter has been out of the car for a while, getting dust and moisture. it seems that is not working. but how can i test the starter out of the car,is a 300e 1987. thanks for any info....
Reply With Quote
Old 07-06-2000, 08:39 PM
engatwork's Avatar
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,232
take it to Advance Auto Parts and ask them to test it for you. They will do it free.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Starter Installation - W126 / OM603 300SDL ccooper Tech Help 2 09-29-2004 07:46 PM
Starter glow plug dash light MarkM Diesel Discussion 1 06-29-2004 02:43 PM
84 300SD Starter Questions SD Blue Diesel Discussion 2 06-11-2004 10:50 PM
300E failed low speed emission test asiamood Tech Help 10 04-28-2003 06:59 AM
new starter - bad already ? surfblau Diesel Discussion 2 06-28-2002 11:48 AM

All times are GMT -4. The time now is 10:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page