Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2000, 05:45 PM
Registered User
 
Join Date: May 1999
Location: Toronto,On,Canada
Posts: 280
Bought 89.5 octane fuel recently because queued before price hike to pump and pump has no 91/2 octane.1/2 tank used ok.
Charged battery prophylactically on sunday without disconnecting.
Tuesday,today car has no power on hiway,slowed down to shoulder,car stalled.Started again ,ok,car still not as powerful as before.Check this list,checked the overvoltage relay fuse,seems ok.Hesitates to put in 120C$ relay if that is not the culprit.May have to check fuel filter,supply etc,3 yrs no change since po??

------------------
Tom 1992 300E 2.6
Reply With Quote
  #2  
Old 07-18-2000, 11:07 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Check the fuse in the top of the overvoltage relay. It is located behind the battery and the plastic cover. The relay will have a 10 amp fuse and a red top. The fuse is a standard 10 amp blade fuse.

------------------
Benzmac:
Donnie Drummonds
1991 GMC Syclone
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 07-18-2000, 11:27 PM
Registered User
 
Join Date: May 1999
Location: Toronto,On,Canada
Posts: 280
thanks,Benzmac,checked red 10A fuse,Okay.
So I guess that ruled out accidental overcharge by automatic batt.charger?

As I said,it may be the fuel supply side if that is the case.

Car seems to run fine now with a mix of 89.5 and 92 octane mix.

May take to dealer as favourite mech on holiday.

------------------
Tom 1992 300E 2.6
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will a 300E trannsmission fit in a 300E 2.6? spsinha Tech Help 5 09-17-2004 11:14 AM
Battery Charge Warning Light come on sanjivsai Tech Help 1 11-20-2003 06:43 AM
Waterpump for 300E 2.6 1990 needed subru73 Mercedes Used Parts For Sale & Wanted 0 09-30-2003 08:38 PM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 01:14 PM
1986 300e mercedes. car stalls when driving miqueas55 Tech Help 2 06-23-2003 07:55 AM



All times are GMT -4. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page