Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2004, 06:40 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
Update about my car

Today, driving approximately 30 mph, the car stalled while driving over a bridge. This also happened rather recently. The drive belt and drive belt tensioner were just replaced about 3k miles ago. The car has also been running kind of poorly lately with a loss in fuel economy and the economy gauge does not go all the way to the left at idle (it is stuck about 1/4 of the way towards the right). I was wondering if any diagnosis can be made based on these symptoms or if anyone has any ideas.
Thanks much
Ben

PS I was thinking of vacuum leaks, a bad battery, and/or bad injectors or seals as the likely culprit. I hope it is not anything like a fuel pump fuel pressure regulator. any ideas on this one?

__________________
currently just 1989 300SE 185k miles
Reply With Quote
  #2  
Old 01-24-2004, 07:45 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
anyone have any ideas?
__________________
currently just 1989 300SE 185k miles
Reply With Quote
  #3  
Old 01-24-2004, 08:51 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
The "economy" gauge is nothing more than a borboun type vacuum/pressure gauge; and your symptoms, coupled with the gauge reading, may point to a vacuum problem. I'd sure be under-hood checking all vacuum connections. Perhaps one was inadvertently budged when the belt was changed.
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #4  
Old 01-25-2004, 12:41 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
bump

__________________
currently just 1989 300SE 185k miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page