Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2000, 09:27 PM
Darryl
Guest
 
Posts: n/a
Just today my oil pressure ,water temp and fuel gauges along with my tach stopped working ,at the same time my AC Compressor's Clutch will not engage......I looked for a blown fuse and all were good.....A couple of hours later I drove the car and everything worked fine again....Just tonight same problem reoccurs....What common link do all of these devices share as it is apparent that the failures are related????????

Thank You , Have a GREAT day!!!!!!
Reply With Quote
  #2  
Old 08-09-2000, 10:03 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You need to replace all of the fuses in the box!! I have posted this in the past. The fuses will appear to be fine, but there will be a hairline crack in the fuse.

I have seen techs replace wiper motors and instrument clusters because of this! Replace all of the fuses!!


------------------
Benzmac:
Donnie Drummonds
1991 GMC Syclone
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 08-10-2000, 09:21 AM
LarryBible
Guest
 
Posts: n/a
Something I learned a long time ago; you can determine that a fuse is bad by looking at it, but you can't determine that it's good by looking at it. If it looks bad it's bad, if it looks good, it's not necessarily good.

Good luck,

------------------
Larry Bible
'84 Euro 240D, 523K miles
'88 300E 5 Speed
'81 300D Daughter's Car
Over 800,000 miles in
Mercedes automobiles
Reply With Quote
  #4  
Old 08-10-2000, 09:43 AM
jerry o
Guest
 
Posts: n/a
I had same problem with my 87 260E with dash gauges going out and back on--turned out to be the fuse that looked good--I found it by swithching instrument gauge fuse with same amp fuse from another circuit.

Jerry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Dash Gauges rolls88 Tech Help 8 03-07-2014 06:25 AM
Gremlins! Demons! Jumping gauges! seacoast_benz SL Forum 8 10-13-2006 05:26 AM
Instrument Cluster Gauges Died S_CLASS_LOVER Tech Help 5 01-20-2005 05:43 PM
Reply from VDO - MB fuel gauges Zeus Tech Help 11 02-25-2002 04:52 PM
intermitten tach rich30769 Tech Help 2 01-31-2001 10:06 PM



All times are GMT -4. The time now is 05:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page