Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-10-2000, 09:51 PM
Registered User
Join Date: Mar 2000
Location: Springfield, MO
Posts: 71
Ok, the A/C works but not very well in, the pressures are as follows:

Low 50psi High 250psi during idle 600rpm
Low 30psi High 275psi during 2000rpm

air is cool but not cold like it should be, outside air was around 95F with 65% humidity

aux fan was running

there are some bubbles in the sight glass, but clearing the sight glass with more charge sends my high pressure upwards of 350 any suggestions, does the aux fan have a high and low speed, I have only seen it spin one speed is that correct?
Reply With Quote
Old 08-10-2000, 11:44 PM
Registered User
Join Date: Mar 2000
Location: Springfield, MO
Posts: 71
my aux fan is working right I jumpered the temp switch on the engine and the fan came on high and then I jumpered the green pressure switch by the reciever and the fan came on low, I have seen some posts saying this green switch should be replace to red, is this true and why, do you have to drain the r-12 to change this pressure switch?
Reply With Quote
Old 08-11-2000, 12:17 AM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
It seems to me that the condensor is not cooling fast enough. Is the condensor clean? Do you have a fan shroud? Is the fan clutch okay?

If you are idling with a/c on during a hot day, do not expect the system to work well. I assume that you know what your car could do when idling in a hot day in the past comparing to what it is now.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W124 A/C Diagnostic djankov Diesel Discussion 14 08-02-2004 11:14 AM
1987 W124 Front End rebuild. Carrameow Tech Help 12 05-28-2004 09:40 AM
W124 300TE A/C Blower fan is not working when the car is running ke6dcj Tech Help 2 10-21-2003 09:07 PM
W124 aux. fans: wiring them ON when A/C on ke6dcj Tech Help 2 07-24-2003 01:01 PM
Rear power window 87 260e (w124) sad 260e Tech Help 11 03-14-2003 09:52 PM

All times are GMT -4. The time now is 04:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page