Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-11-2000, 03:54 PM
Posts: n/a
My mother has a 1996 E320 with 30k original miles in pristine condition owned since new. The car has never been in an accident and has rarely been on the freeway. The car has always had a problem of periodicly not starting. This does not happen often. When it cannot start it still has full power to accessories but will not start. The car has been to the dealer to have many things such as computer boards, batteries, wiring replaced but the problem persists. Now that it is out of warrantee I am worried that she will be paying big $$ to "repair" the problem or worse, get stranded somewhere. Does anyone have an idea what may cause the car to start sometimes and not the other? The car has had absolutely no mods to it-no aftermarket alarm. Thank You.
Reply With Quote
Old 08-11-2000, 04:19 PM
Posts: n/a
Forgot this: Can anyone comment on the reliability of this car-are they "keepers" or are they prone to problems. I believe that they are the only year with the straight-six which my mechanic suggests will last a long time. Thanks again for any information on this car.

Dan Latta
'00 ML 320
'99 ML 430
Reply With Quote
Old 08-11-2000, 05:44 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
On the 1996 E-class the electrical portion of the ignition switch seems to be somewhat a common failure with the no-starter symptom.

27 YEARS DEALER M.B. Shopforeman
1986 190E 16V
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
intermitent dead battery ("+*#!) MarkM Diesel Discussion 7 12-17-2004 08:11 AM
All Dash Gauges are dead lee00058 Tech Help 12 11-18-2004 03:32 PM
E320 95 turn signal does not work duc4208 Tech Help 4 09-05-2004 01:36 PM
Help Please! Climate Control Unit Dead - 95 E320 fmajid Tech Help 4 03-20-2004 01:57 AM
Can I recharge the dead battery from my E320 -'95 fhmajid Tech Help 6 10-14-2002 11:21 AM

All times are GMT -4. The time now is 08:03 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page