Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2004, 09:01 PM
chazola's Avatar
Registered User
 
Join Date: Nov 2003
Location: London, United Kingdom
Posts: 1,241
300E flickering interior lights

I may be being really pedantic, but I noticed on my 300e some of the interior lights flicker slightly when the car is running, most noticeably the backlight for the temperature lcd and the overhead courtesy light- it isn't really a bad pulsing, like on and off, but more like a slight rapid flickering several times a second, where the light goes slightly dimmer. Is this sign of impending faliure of something or just normal behaviour?

I recently had my alternator regulator replaced, if that makes any difference.

__________________
1993 320TE M104
---------------------------------------------------
past:

1983 230E W123 M102
1994 E300D S124 OM606 (x2)
1967 250SE W108 M129
1972 280se 3.5 W108 M116
1980 280SE W116 M110
1980 350SE W116 M116
1992 300E W124 M103
1994 E280 W124 M104
----------------------------------------------
"music and women I cannot but give way to, whatever my business" -Pepys
Reply With Quote
  #2  
Old 03-25-2004, 09:53 PM
Evan's Avatar
Registered User
 
Join Date: Nov 2003
Location: Fairhaven MA
Posts: 299
I would have suggested the Voltage Regulator, however you have already replaced that. I would check connections at the alternator really. Check the battery for its strength. Does the RPM's seem to affect the lighting problem that you are experiencing..
__________________
2001 Mercedes-Benz C320 3.2
1991 Mercedes-Benz 300E 3.0
Reply With Quote
  #3  
Old 03-25-2004, 10:54 PM
chazola's Avatar
Registered User
 
Join Date: Nov 2003
Location: London, United Kingdom
Posts: 1,241
RPM seems to have an effect, at idle the flicker is most noticeable, and it gets a bit less so as the RPM goes up. My idle is very steady, no surging or any or other strange business, though I get a bit of shake from the front at standstill (I think that's worn out motor mounts though).

My tech said the alternator could be on it's way out when I had the regulator replaced, but also said they usually last up to around 230k and to see how it goes.
I'm due an oil change soon so I'll see what he says.

__________________
1993 320TE M104
---------------------------------------------------
past:

1983 230E W123 M102
1994 E300D S124 OM606 (x2)
1967 250SE W108 M129
1972 280se 3.5 W108 M116
1980 280SE W116 M110
1980 350SE W116 M116
1992 300E W124 M103
1994 E280 W124 M104
----------------------------------------------
"music and women I cannot but give way to, whatever my business" -Pepys

Last edited by chazola; 03-25-2004 at 11:28 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page