PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   83 300CD tranny modulator question (http://www.peachparts.com/shopforum/tech-help/91335-83-300cd-tranny-modulator-question.html)

freesprung 04-07-2004 11:10 PM

83 300CD tranny modulator question
 
Just bought this thing and I am working through the many
typical problems. Todays challange is the hard 1-2 shift. Based on posts from those who have gone before me I
measured the vacuum at the modulator valve on tranny and it holds for more like 5 seconds than the 5 minutes specified.
So here is the question: Do I certainly need a new modulator
or should I try a new O ring seal first? Some where I read that
the O ring can solve the leaky modulator problem. (I have the
"updated" green one by the way).
Or am I barking up the wrong vacuum line?

Oh yes, one other question if I may. Is it normal that the
gas (or should I say diesel fuel) pedal should move an inch or more before anything happens to engine RMP? Linkages seem OK.
Seems like the first inch or two of pedal travel is to open and close switches and vacuum valves but not increase engine speed.
Or could question 2 be related to question 1?

Thanks for all your help and suggestions!
Chad


All times are GMT -4. The time now is 12:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website