Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-01-2000, 12:55 AM
Posts: n/a
i have an 84 190e 2.3 8v and everytime i start my car it usually takes a couple of times of turning the key, i could hear it trying to start but it takes a couple of times and once it starts, i try to warm up the engine by revving my car and i step on the gas and quickly hit twenty on my rpm gauge, it looks like it is about to die and sometimes it does and have to restart the car, and after a couple of minutes of warming up, it is okay and after when im driving and reach my destination and put it in either park or neutral, my rpm goes up to 15 when usually it is like around 9 or 10...thanks for any input
Reply With Quote
Old 09-01-2000, 01:11 AM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Check your overload relay,is right behind your battery with a red fuse (10 amp)at top.
hope this help.

MB STARS Master Guild Technician,12 years MB tech
6 years independent shop owner
Reply With Quote
Old 09-03-2000, 12:03 AM
Posts: n/a
thanks for the info, it reduced the rpm idling back down to around 11-12 but i still have a hard time starting and sometimes it doesnt have that dying out sound when i step on the gas, thanks again and i would appreciate any other info you might have...
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 190E Starting Problem Rtbnsn1 Tech Help 0 09-08-2004 03:25 PM
Hard starting for 85 190E classic69 Tech Help 4 10-21-2003 08:19 AM
1987 300D Turbo Glow plug light out. hard starting jfikentscher Diesel Discussion 2 11-13-2002 12:54 PM
New clue to hard starting problem Spencer 300E Tech Help 4 11-11-2002 11:44 PM
Rough cold starting 190E 2.6 G.W. Pettry Tech Help 0 09-29-2001 08:51 AM

All times are GMT -4. The time now is 12:45 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page