Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-19-2004, 07:21 AM
Registered User
 
Join Date: May 2004
Posts: 8
Smile Hello all; Newbie questions..

Hi everyone!

I'm new to the world of MB, but I've been working on air-cooled 911s my whole life so you'll have to pardon my ignorance!

I just got the wife a 1999 E320 4matic wagon with 67k miles. What grade oil (I assume Mobil1) does MB recommend? 10/40? (I don't have an owners manual yet.)

Also- I'm getting a PO442 error code- something to the effect of EVAP emission control system leak. Where should I start to troubleshoot this? I'm hoping it's just a cracked hose or loose fitting but any light you can shed on this would be helpful.





What else should I lookout for on this car? I read about the main crank pulley issue, that sounds ugly and I'll probably just replace mine to get ahead of it. What else...????

Many thanks in advance- this looks like a great forum!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page