Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-23-2000, 02:27 PM
Registered User
Join Date: Aug 2000
Posts: 4
On my 93 500SEL (19K miles), about once a week (for the last month) and usually when the humidity is high, the following occurs: Once I switch the right turn signal, the indicator and the exterior lights "stay on" even after I move the switch to neutral. It stays on even if I switch off the ignition. The only way I've been able to return it to normal operation is activate the four way flasher once and after the lights flash, the turn signal switch returns to normal and usually doesn't fail for about another week.

Any ideas on how to fix this--I've had the car since the first week in July and still can't wipe the smile off my face.

'93 500SEL
'84 300SD(Donated as a tax write-off at 240K)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent turn signal failure (1985 380SL) Southin SL Forum 6 10-13-2003 05:14 PM
Can't Hear the Turn Signal Click! bmcglamery Tech Help 1 09-27-2003 01:08 PM
turn signal problem after steering box R&R rvolheim Tech Help 3 06-07-2003 04:19 PM
turn signal problem - 16V slk528 Tech Help 1 06-19-2002 05:56 PM

All times are GMT -4. The time now is 07:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page