Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-26-2000, 01:04 PM
Posts: n/a
Hi all, my E200(1994) water temperature has been acting up recently.Temperature used to range from 80-87 degrees C. But increased to 90-100 degrees C. After changing to a new radiator, temperature range is 79-93 degrees C. At times, temperatures could go up to 97 degrees C in stationary position. Is this within the correct oprating range? Could the thermostat be faulty? (I come from a tropical country:Singapore)Or issit the temperature sensor??
Reply With Quote
Old 09-26-2000, 01:35 PM
yal's Avatar
yal yal is offline
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,704
1. Did you change the radiator to an equivalent tropical one to the one you had in there?

2. It is always advisable to change your thermostat after doing any kind of major work on your cooling system.

3. What was the new radiator filled with? Check your manual I believe that in tropical climates you need a slightly higher mix of water to anti-freeze (yes anti-freeze) (70-30 split if I remember correctly).

88 230E (W124)
smoke/red tailights
98 e420 sport replicas

[This message has been edited by yal (edited 09-26-2000).]
Reply With Quote
Old 09-26-2000, 07:25 PM
Posts: n/a
Yes, the water/antifreeze mixture was also changed. I guess the proportion was also 70-30. The new radiator was changed based on the part number of the original one which was installed in my car. Besides the radiator, no other changes/repairs have been made to the cooling system. Any ideas??
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with the water temperature? zeemax Tech Help 1 12-23-2004 09:06 PM
High Water Temperature MicroRacer Diesel Discussion 5 12-29-2003 09:57 AM
Losing Water 1991 300 SEL Motor Head Tech Help 2 12-13-2003 02:40 PM
Water problem! TROVERMAN Tech Help 2 11-25-2003 12:42 PM

All times are GMT -4. The time now is 09:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page