Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-01-2000, 08:39 PM
Registered User
 
Join Date: Aug 2000
Posts: 4
Thanks to all who support this site--it really is well done and very helpful.

On my 93 500SEL (19K miles), about once a week (for the last 5+ weeks) and usually when the humidity is high, the following occurs: Once I switch the right turn signal, the indicator and the exterior lights (right front and right rear) "stay on" even after I move the switch to neutral. They stay on even if I switch off the ignition. The only way I've been able to return the system to normal operation is to activate the four way flasher for several "flashes" and after the right indicator flashes, the turn signal switch returns to normal and usually doesn't fail for about another week. This is starting to occur more frequently and under less humid conditions.

Should I replace the bulbs on the right side--is there a "flasher" unit that might be failing or should I take it in for service?

Thanks.

DDS


------------------
'93 500SEL
'84 300SD(Donated as a tax write-off at 240K)
Reply With Quote
  #2  
Old 10-01-2000, 09:21 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The combination relay is sticking & will need to be replaced.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent turn signal failure (1985 380SL) Southin SL Forum 6 10-13-2003 06:14 PM
Can't Hear the Turn Signal Click! bmcglamery Tech Help 1 09-27-2003 02:08 PM
turn signal problem after steering box R&R rvolheim Tech Help 3 06-07-2003 05:19 PM
93 500SEL Turn Signal dsprouse Tech Help 0 09-23-2000 03:27 PM



All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page