Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-21-2000, 07:34 AM
Posts: n/a
The 4matic indicator light is staying on
in my 1991 300TE 4m. I have already replaced
the stop light switch,and it still stays on. Does anyone else have an idea of what to check next?

1987 16v
1991 300TE 4m
Reply With Quote
Old 09-21-2000, 10:33 AM
Posts: n/a
If you're saying that the yellow triangular light in the middle area of the speedo is staying on, it means that the car is stuck in awd. I'd suggest taking it to a repair shop. If you're saying that the squarish indicator light lower in the dash is coming on and staying on that means that there's something not working with the AWD system.

Other than the light is the car behaving any differently than usual? If it is, it would probably be a good idea to call Mercedes directly at 1-800-4-mercedes and check with them about whether the car should be driven.
The 4-matic system is very complex, and differs from just about every other awd system. Consequently I would recommend either a MB dealer's shop or a *very* high volume independent shop for troubleshooting the problem. There are very few 4-matics around and unless someone is familiar, you might spend a lot for someone making potentially a bad guess about the problem.

Good luck!

Reply With Quote
Old 10-03-2000, 01:35 PM
Posts: n/a
What was the problem found? I just had the same thing.
Reply With Quote
Old 10-04-2000, 06:38 AM
Posts: n/a
If your 4matic warning lamp is on - the one in the lower light panel (not in the instument cluster) then it would be a v good idea to put the car in 2 wheel drive mode, and get to your dealer.

(the lever to switch to 2wd mode is in the engine bay! look in your owners manual for the exact location)


Reply With Quote
Old 10-04-2000, 08:13 AM
Posts: n/a
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by RobJ16v:
The 4matic indicator light is staying on
in my 1991 300TE 4m. I have already replaced
the stop light switch,and it still stays on. Does anyone else have an idea of what to check next?

My problem is now solved, here's what happened:
1. When the 4M light(the one on the lower right of dash, not center off speedo)first came on, I converted the car to 2-wheel drive mode (as suggested in the owners manual, and by one reply to the posting)using the "test" lever (de-activates hydraulics).
2. After replacing the stop light switch (which is the most likely failure mode)to no avail, I gave in and brought the car to the dealer.
3. Interestingly the dealer informed me that when an owner releases the 4M with the "test" lever, it will clear the error code in the 4M computer memory. So they don't advise using the "test" lever unless the 4M ACTIVE light stays on in the center of the speedo ( which is really what the owners manual says too.)
4. After reactivating 4Matic and driving to produce a new error/fault, the dealer checked the computer. The computer told them the problem was a bad STOP LIGHT SWITCH.
5. I informed them that I had just replaced the stop light switch with a genuine Mercedes part; we verified again that the 4matic uses the same stoplight switch as a regular 300E.
6. A little stumped, the mechanic contacted MB Engineering. Mercedes told him to bleed the 4M hydraulic system. Thankfully, this cleared the fault condition.
Problem solved.

Thanks to all who replied!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: The oil pressure light stays on toka Tech Help 4 11-22-2008 04:44 PM
1992 W124 factory option 662 5 spk sprt wheels? moruzzi Wheels & Tires 6 02-13-2004 03:40 PM
dome light jivadent Diesel Discussion 7 01-24-2004 02:33 AM
Problem with rear dome light switch 420SEL William Tech Help 2 11-10-2003 03:46 AM
Mysterious Lamp Defect Warning light on 97 W210 E320 ken320 Tech Help 1 08-09-2001 08:25 AM

All times are GMT -4. The time now is 02:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page