Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-18-2000, 10:46 PM
Registered User
Join Date: Aug 2000
Posts: 17
The cruise control on my 1988 300TE disengages after 10-15 minutes of highway driving. It will reset, but does the same thing over and over. Any suggestions?
Reply With Quote
Old 09-19-2000, 12:18 AM
Registered User
Join Date: Jan 2000
Location: PA
Posts: 5,440
Replacing the cruize control circuit card fixed my car with a similar problem.
Reply With Quote
Old 09-19-2000, 11:29 AM
Posts: n/a
You may want to search the archives for repair suggestions. I fixed mine by removing cruise control circuit card and re-soldering. Good luck.

1986 300SDL 173K
1985 300D [sold]
1996 Explorer 62K
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control problem C180 1997 Update merclover2004 Tech Help 1 04-19-2004 04:02 PM
'92 190E Push Button Climate Control Problem !*mr.bones!* Tech Help 4 04-29-2002 03:32 PM
Cruise Control stops at 60MPH Austin814 Featured Cars 2 01-13-2002 11:02 AM
Cruise Control Problem ('85-300D) benz-rookie Diesel Discussion 3 10-08-2001 10:43 AM
560SL Cruise Control Problem Bob Cavazos Tech Help 1 04-16-1999 01:26 PM

All times are GMT -4. The time now is 08:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page