PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   intermittant check engine light 88 300E (http://www.peachparts.com/shopforum/tech-help/9831-intermittant-check-engine-light-88-300e.html)

phunkler 10-13-2000 07:32 AM

Problem #1 with this 168,000 mi. 88 300E is an intermittent check engine light. If the car is idling and the lamp comes on, idle speed drops to about 500 rpm and becomes rough. If the car is at cruising speed and the light comes on it seems to loose power and run a little rough. I would rather not guess at the problem if it can be diagnosed. I did note recently that with the key on and engine off after about 2 minutes the idle speed air valve began to randomly cycle open and shut. With engine running and the check engine light off I believe the computer output signal is normal at 40% duty cycle. I have changed the following items with no change in symptoms: oxygen sensor, fuel pump relay, overvoltage relay, ignition wires, plugs, cap, rotor, air filter, and fuel filter. Other recent work that I have performed on the car has been a transmission replacement(the intermittend light preceeded the tranny change out also). What do I do next? I took the car to the shop associated with the local mercedes distributor and the O2 sensor was replaced on his recommendation. When I measured on output the old sensor indicated normal but I figured he would know if O2 sensors typically fail with intermittant symptoms. I'm considering buying a diagnostic tool(oscilloscope) to check inputs and output on the CIS E computer but I would also need to build or borrow an electrical socket box for the wiring harness. I was hoping the shop could do this but he only checked the computer output(duty cycle) while the check engine lamp was on and suggested first changing the O2 sensor and then changing the CIS-E control unit.

I'm reluctant to change the CIS-E computer ($1000) without knowing that it is broke! Does anybody have a loaner? With my luck so far it would be something else like ignition coil, engine speed sensor, ignition control module, fuel pump, loose wire, poor solder joint, altitude sensor, air flow sensor bad ground, etc. infinity

Any reasonable suggestions are appreciated please.

stevebfl 10-13-2000 08:55 AM

Each version KE has different meanings attached to the Duty-cycle IR values coming from the left side diagnostic port. Your year should give 70% key on engine off. If its a Ca version it should be 85%.

While running a fixed duty cycle indicates a code/fault. A 40% fixed duty-cycle would indicate a problem with the airflow sensor position indicator (B2). While running in closed loop the duty cycle will vary up and down as the mixture is corrected rich-lean. A properly adjusted car will have the oscillating duty cycle hovering around 50%. I usually bias my settings rich by setting mixture to a hover over 40%. It must be moving though to get a value otherwise a code is being set.


All times are GMT -4. The time now is 12:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website