Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-18-2000, 09:24 PM
tilford61
Guest
 
Posts: n/a
I recently purchased a 1986 sdl 173000 and am experiencing lag time in reverse and in forward as much as 2 seconds which seems like eternity. Also i cannot downshift when I need it. I love this car but this problem impedes my enjoyment. Is there someone out there to help me? Thanks Tom
Reply With Quote
  #2  
Old 10-18-2000, 09:44 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Have the tranny checked, especially the oil pressure at idle. Could also be a grungy valve body. May need a change and a new filter.

------------------
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
Reply With Quote
  #3  
Old 10-18-2000, 11:24 PM
MBZ.Ian
Guest
 
Posts: n/a
More than likely the LB3 clutches are worn out, actually that is a safe bet.
LB3 clutches are for reverse only and are located behind the front pump housing surrounding the K1 drum.
Transmission has to be R & R to access. remove the filter first, open and inspect for clutch and metal material. If present trans has to come apart.

------------------
Mercedes-Benz Master Guild - 2 years
Shop Foreman - 20 + years - dealer.
Part owner - MBZ Transmission remanufacture
2000 SL500
1999 ML430
1989 300SE
Reply With Quote
  #4  
Old 10-19-2000, 08:55 PM
Michael's Avatar
Veteran
 
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Ian,

Are you sure? Just kidding...sounds like Tom needs to visit you. Sorry Tom!

------------------
All the best, Michael
500E
300TE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
S 500 Mercedes problems DawnATL Tech Help 0 09-13-2002 10:20 PM
Tranny vibes md21722 Tech Help 0 08-03-2002 04:40 PM
Problems on e420 tranny jchowe420 Tech Help 2 10-21-2001 01:29 PM
Tranny problems with bad shaking WmHarlow Tech Help 2 10-31-2000 12:28 PM



All times are GMT -4. The time now is 06:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page