Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2000, 05:35 PM
Stevet104
Guest
 
Posts: n/a
Cannot seem to get air or heat out of the center vents on my 85 500SEL 120K. Side vents work OK. No other problems with heat or air.



------------------
Steve in Albuquerque
Reply With Quote
  #2  
Old 10-23-2000, 06:49 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You may have a leak in the vacuum system or a faulty vacuum actuator for that function.

------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
OWNER OF MB AUTOWERKS .COM
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
center vents not working on 560SL lynns SL Forum 50 08-01-2011 12:53 AM
center vents not working on 560SL lynns Tech Help 1 04-03-2004 03:27 PM
Center Vents not working...Yes, I know this is a common problem RickM SL Forum 6 07-16-2003 08:47 PM
Bi-level center vents blows no heat A Khan Tech Help 1 12-11-2002 02:26 PM



All times are GMT -4. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page