Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2008, 11:21 AM
Registered User
 
Join Date: Feb 2001
Location: BC, Canada
Posts: 378
Automatic trans slip problem - 280SL

It drives fine for a while and then will start to slip or flare.
If I stop the car it generally settles down for a while.
A shop I talked to said that SL transmissions were different
than SE ones. Is that right? I'm going to get the model
number off it on the weekend. It has had the fluid and
filter changed with no effect. There aren't any leaks.
Thanks for all comments!

__________________
VR
1967 250SL
Reply With Quote
  #2  
Old 03-14-2008, 03:04 PM
Registered User
 
Join Date: May 2006
Location: Atlanta, GA
Posts: 299
Address this at the following for more responses:

www.sl113.org

__________________
All the best,

J. P. Mose
1968 250SL
1970 280SE 3.5 Cabrio
1987 560SL
1990 560SEL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page