Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2001, 01:28 PM
we300b
Guest
 
Posts: n/a
1969 280SL problem

What might be the cause of a lumpiness / bucking when driving slowly in first or second gear? These are the symptoms:

-slightly lumpy acceleration from 1000 to 2000 RPMs
-bucks when maintaining speed 1000 to 2000 RPM on a slight incline (1st/2nd gear)
-downshift "burbles" from 2000 to 1000 RPM
-idle no problem
-higher RPMs are fine
-throttle linkages are adjusted properly

Does this sound like an ignition problem? Fuel injection? Fuel pump? Vacuum advance?

Thanks in advance for your help,

Steve
1969 280SL 4 speed

Reply With Quote
  #2  
Old 08-07-2001, 11:09 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935
Have you looked at your points and checked the dwell angle?
__________________
Regards,
Aaron
Reply With Quote
  #3  
Old 08-08-2001, 03:03 AM
we300b
Guest
 
Posts: n/a
Points and dwell are OK, but the fuel pump has been noisy for some time (screech). Could that be the cause? The 280SL is fuel injected.

Thanks,
Steve

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Euro 280SL Clutch Problem ctaylor738 Tech Help 0 10-14-2004 12:55 PM
1992 300CE W124 Doorlock Problem Ashman Tech Help 10 07-31-2004 10:37 PM
Tormenting Problem with 95 E320 (Long) JetForeman Tech Help 16 10-01-2003 11:57 AM
nice 1969 300SEL 6.3 for sale, Portland OR gerryvz Mercedes-Benz Cars For Sale 0 06-23-2003 07:09 AM
280sl - is this a distributor or vacuum problem? we300b Vintage Mercedes Forum 5 06-23-2002 12:04 AM



All times are GMT -4. The time now is 11:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page