Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 01-02-2009, 08:52 PM
280EZRider's Avatar
No Dumping
 
Join Date: Jul 2007
Location: Southern Oregon Valley
Posts: 1,590
Quote:
Originally Posted by wolf_walker View Post
Been running the tighter listed specs since the 25th, also switched to an old favorite oil of mine, Rotella 5w40 synthetic. Car seems happy, valve noise is low, no smoke, no oil usage.
I have been using Mobil 1 0w40 for the last few months mainly as a clean-out for the cam bearings. This oil finds places to weep occasionally, but mostly on the sensor block of the M110. I'll probably switch back to conventional oil, but it's currious that sometimes the engine will suck back in oil on the sensor block leaked from the previous day. Has anyone had this happen?

__________________

Don't Chrome them; polish them
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page