Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-13-2010, 10:05 PM
Registered User
 
Join Date: May 2008
Location: NY
Posts: 204
Putting out the call

to help a fellow W116 enthusiast in Akron, OH. I have a friend who has a '78 280SE. His car has been at the "mechanics" for months with not much resolution to his problems. My friend believes that his car needs a new head (I thought these to be pretty robust engines ) and it needs a new exhaust as the old one was quite a chop job sans resonators and cats and a rotten muffler.

What he needs is a referral to a reputable shop in the area, or a very helpful board member willing to assess, diagnose and maybe repair.

I have a full exhaust and an engine (can't quite comment on condition as I am unsure myself, but willing to get to him for near nothing to help) but I need to get it to Akron cost effectively for it to be helpful.

Has anyone on here ever participated in a transport effort similar to that of a chain gang?

For being a relatively new member I am asking a lot. I guess I care about the propagation of the 116 chassis and want to do al I can to see one stay on the road.

Thoughts, comments, criticisms?

P.S. I will be posting this on every MB board I belong to

Reply With Quote
  #2  
Old 07-13-2010, 10:23 PM
daw_two's Avatar
diesel enthusiast
 
Join Date: Jan 2007
Location: Germantown, TN
Posts: 5,449
MB_Mike

Please post your location. I have a trip planned toward Dearborn Heights, MI for later this year; however, I will already be carrying one engine and transmission, so space may be limited.
__________________
daw_two
Germantown, TN

Links:
Sold last car --- 05/2012 1984 300D Light Ivory, Red interior
Cluster Needles Paint
New Old Stock (NOS) parts

Past:
3/2008 1986 300SDL "Coda"
04/2010 1965 190D(c) "Ben"
& many more
Reply With Quote
  #3  
Old 07-13-2010, 10:47 PM
wbain5280's Avatar
Registered User
 
Join Date: May 2001
Location: Northern Va.
Posts: 3,386
What is actually wrong with the car?
__________________
Regards

Warren

Currently 1965 220Sb, 2002 FORD Crown Vic Police Interceptor

Had 1965 220SEb, 1967 230S, 280SE 4.5, 300SE (W126), 420SEL

ENTER > = (HP RPN)

Not part of the in-crowd since 1952.
Reply With Quote
  #4  
Old 07-13-2010, 10:53 PM
Registered User
 
Join Date: May 2008
Location: NY
Posts: 204
I am in Auburn, NY but my friend is in Akron, OH. I am not 100% sure what is wrong with his car. What I posted is the info I have right now.
Reply With Quote
  #5  
Old 07-15-2010, 08:03 AM
wbain5280's Avatar
Registered User
 
Join Date: May 2001
Location: Northern Va.
Posts: 3,386
Please ask your friend to either post the problem(s) and/or symptoms, or relate them to you so you can post them. Pictures will help too.
__________________
Regards

Warren

Currently 1965 220Sb, 2002 FORD Crown Vic Police Interceptor

Had 1965 220SEb, 1967 230S, 280SE 4.5, 300SE (W126), 420SEL

ENTER > = (HP RPN)

Not part of the in-crowd since 1952.
Reply With Quote
  #6  
Old 07-16-2010, 02:21 PM
Registered User
 
Join Date: Dec 2007
Location: Houston, Texas
Posts: 1,137
Quote:
Originally Posted by MB_Mike View Post
need to get it to Akron cost effectively for it to be helpful.

I recently used uship.com to ship a car. You can post what you need shipped and the transport companies will bid on it.
__________________

1962 220Sb ~ The Emerald Bullet http://www.youtube.com/watch?v=hx6tN1W48_o
1957 Ponton 220S

2001 S600 Daily Driver
The Universe is Abundant ~ Life is GOOD!http://www.classiccarclock.com
Reply With Quote
  #7  
Old 07-19-2010, 01:34 PM
Registered User
 
Join Date: May 2008
Location: NY
Posts: 204
Here is what he has to say about the car

Thanks Mike,
I have a little information, not much.

Apparently there are two cylinders that tested as low pressure, 60 lbs vs the 100 he said they should have.

The car had a valve adjustment, ran rough immediately, began blowing blue smoke obviously right after I had the catalytic converter and center muffler cut off at the mechanic's directive, as he felt the catalytic converter may have been bad and putting too much back pressure on the engine. (his words), and the center muffler had a hole in it. After the converter was cut off the car immediately was blowing a good bit of smoke all the time. Ran through a lot of oil in three days. The mechanic tested it and said it was the head,(leaking oil too) and the valves. The catalytic converter was broken inside, and oily. The car has always had very poor acceleration, since I bought it last December. It did not run rough though until the valve adjustment was done.

Since I purchased the car "in top shape, no mechanical nor body faults", I have been replacing all kinds of parts. Shocks, stabilizer links, entire airconditioning/heating system (only blower motor and heater core are original now), both windshields (leaking badly), most rubber parts need to be replaced, transmission would not shift properly, engine wiring bad, seat adjusters were broken, entire rear seat assembly had no foam anymore so I replaced the foam in both rear seat parts, radio bad, speakers bad (replaced radio -new sony I had in old car, and two rear speakers but almost no sound comes out of back speakers, passenger door latch shattered from the accident that damaged the door probably, door catches to keep them open are not working, locking mechanisms do not work, cruise control broken --nearly killed me on highway when it would not turn off (needs some computer part) , fuel accumulator and distributor are bad, steering is loose, starter is bad, alternator is wrong alternator. I know the front shocks, all door rubber gaskets(have fronts purchased), front suspension rubber parts, all need to be replaced soon too. It is basically a pretty good body, liveable interior in front, functioning transmission (though it sure winds up high rpm--3800 on highway) and working brakes and rearend.

It is not fun to drive, very slow, very rough ride, loud at highway speed even when exhaust was ok). Not what I thought the top of the line Mercedes of its era would be like at all. No quiet luxury to this car at all. It is heavy and clearly a tank in construction though. Not likely to fail structurally. :^)
Reply With Quote
  #8  
Old 07-19-2010, 05:14 PM
Registered User
 
Join Date: Apr 2003
Location: Phoenix Arizona. Ex Durban R.S.A.
Posts: 6,104
Quote:
Originally Posted by MB_Mike View Post
cruise control broken --nearly killed me on highway when it would not turn off (needs some computer part)
I'm no expert but I've never heard of this happening before. I've heard of it not turning on of course but not turning off? Doesn't the cruise control disconnect by tapping the brake pedal which causes the activatoin of a bulb in the break lights which in turn causes the cc to disconnect? Could a problem witth that instead of the cc circuit board be the problem?

Once again I'm no expert on this, just wondering about what I'd read about it in the past.

- Peter.

__________________
2021 Chevrolet Spark
Formerly...
2000 GMC Sonoma
1981 240D 4spd stick. 347000 miles. Deceased Feb 14 2021
2002 Kia Rio. Worst crap on four wheels
1981 240D 4spd stick. 389000 miles.
1984 123 200
1979 116 280S
1972 Cadillac Sedan DeVille
1971 108 280S
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2024 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page