Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-20-2013, 01:51 AM
Registered User
 
Join Date: May 2012
Location: Orange County/Bozeman
Posts: 198
W114, only passenger side defrosts windshield.

So I discovered today while driving in the rain that only the passenger side windshield vents are open. Drivers side stays fogged up while the passenger side is crystal clear. Has anyone been inside that area of the car to know what causes that? I assume the sliders control the flaps via some cable, maybe one snapped or came loose. If the slider controls are a pain I'd at least like to get the windshield flaps in permanently open rather than closed. Please let me know!
Reply With Quote
  #2  
Old 05-20-2013, 10:04 AM
WANT '71 280SEL's Avatar
I'll Go Upside Your Head!
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 3,378
I'm betting the hose that goes to the L side windshield vent is disconnected or missing. It typically happens on the driver's side because that's where people are typically in the dash doing something like instrument cluster or ignition work. There is no control to separate the L from the R side windshield vents.

Best Regards,

David
__________________
_____________________________________________

2000 Honda Accord V6 137k miles

1972 300SEL 4.5 98k miles

_____________________________________________
Reply With Quote
  #3  
Old 05-22-2013, 06:40 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,339
W114 chassis have left and right hand heater cores and controls for heat.

If the left side isn't defrosting, it may also be because of a no heat condition on the left side.

Heat is regulated by a valve on the firewall, controlled by a bowdin cable.

Jim
__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
  #4  
Old 05-22-2013, 08:04 PM
Registered User
 
Join Date: May 2012
Location: Orange County/Bozeman
Posts: 198
I'm getting heat on the drivers side dash vent. I should add there is no air flow to the drivers side windshield, whereas the passenger side is getting air.
Reply With Quote
  #5  
Old 05-23-2013, 08:26 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,339
Quote:
Originally Posted by ssk831 View Post
I'm getting heat on the drivers side dash vent. I should add there is no air flow to the drivers side windshield, whereas the passenger side is getting air.
Then it's an airflow problem.

The defrost uses a single fan, located in the most remote location possible in front of the heater core. If you are getting airflow to the pax side, then as suggested, it must be a disconnect or blockage to the defrost outlet.

Jim
__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page