Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2013, 09:58 AM
Registered User
 
Join Date: Mar 2013
Posts: 39
w114 230 zenith carburator problem

Hi guy's , i've been trying to start my '71 230 that i've bough for parts earlier this year.

Yesterday i've installed an ignition coil and got fire to the plugs.

Poured 10 litres of fuel in the tank and tried to start it.

The mechanic fuel pump worked as the fuel filter filled up.

The fuel line between both carburator are full of fuel , yet no fuel seems to enter the carburator.

I've tried to put a small amount of fuel directly in the carbs and it start right up.

Soo , is there a shut-off solenoid on those zenith carburator ?

Or do you have any idea what my problem might be ?

Thanks !

Reply With Quote
  #2  
Old 08-11-2013, 01:49 PM
Pooka
 
Join Date: Sep 2005
Posts: 664
1971 was a weird year for emission controls. I don't know about the Zenith, but I do know that the Solex that came on VW's that year had such a fuel shut off.

Look for a small cylinder shaped thing with one wire going into it. The wire is 12v + and the thing is grounded through the body of the carb. It will also be mounted on the carb but it might not look like it is in the right place to shut off fuel.

All it did was shut off the fuel as soon as you turned off the key, so I guess it was in the normally closed position and opened when it was energized.

Google Zenith carb fuel shut off and see what comes up, but it sounds like this might be something to check out. I do know these items had a high failure rate.
Reply With Quote
  #3  
Old 08-11-2013, 02:43 PM
Registered User
 
Join Date: Mar 2013
Posts: 39
Thanks for the fast reply.

I dismantled the top of both carbs and cleaned them , there was quite a bit of gunk in there.

Closed the back and turned the engine over... it started on his own with a great idle.

As soo as i touch the throttle it stalls.

From what i've seen on the internet soo far i've spotted the (shut-off solenoids) but i can start the engine with them plugged or not and the car still starts and stop with the ignition...

I'll continue to investigate on the carbs , ttyl.
Reply With Quote
  #4  
Old 08-11-2013, 02:48 PM
Registered User
 
Join Date: Mar 2013
Posts: 39
Pages 12-13: Idle Fuel Shut-Off Solenoids

Those are the same as on mine.

When i jump 12v on them , i can't hear them click , yet , the OEM wire that goes to them get 12v when i turn the ignition on.
Reply With Quote
  #5  
Old 08-11-2013, 05:22 PM
Registered User
 
Join Date: Jul 2012
Location: Mooresville, NC
Posts: 159
Needle and seats in the carbs may be stuck shut if they have been dry for a while. You'll have to pull the tops off the carbs and check to see if the valves above the floats operate. Jaime Koop has the Zenith manual online, you could search this site or Google, maybe some one can post link.

__________________
1968 230 W110
1985 300TDT W123/S123
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page