Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2018, 08:39 AM
Registered User
 
Join Date: Oct 2015
Posts: 134
1976 280c no power to powerwindows

power windows are receiving no power at the fuse box. did clean terminals and replaced both 16 amp fuses . still no power? any ideas how to test fusebox . ground points locatations in powerwindow systems .
Reply With Quote
  #2  
Old 05-25-2018, 08:59 AM
Registered User
 
Join Date: Jan 2006
Location: Tucson, AZ
Posts: 4,188
Fuse box? Are you referring to the separate fuse block located on the RH firewall? Unless the ignition is in the "run" position you won't have power to those terminals.
__________________
“Whatever story you're telling, it will be more interesting if, at the end you add, "and then everything burst into flames.”
― Brian P. Cleary, You Oughta Know By Now
Reply With Quote
  #3  
Old 05-25-2018, 09:13 AM
Registered User
 
Join Date: Oct 2015
Posts: 134
powerwindows no power

yes the fusebox on firewall ill go double check with key on
Reply With Quote
  #4  
Old 05-25-2018, 11:20 AM
Registered User
 
Join Date: Oct 2015
Posts: 134
Quote:
Originally Posted by Mike D View Post
Fuse box? Are you referring to the separate fuse block located on the RH firewall? Unless the ignition is in the "run" position you won't have power to those terminals.
double checked even with key in pos 2 no power to powerwindow fuse box on pass firewall took out fuse box going to soak the screws in vinegar and clean brass with fine emery then dielectric grease brass end for the fuses
Reply With Quote
  #5  
Old 05-25-2018, 01:08 PM
Registered User
 
Join Date: Oct 2012
Posts: 8,941
Anyone have a wiring diagram they can post?

And... Are there any other electrical items that are not working on this car?
Reply With Quote
  #6  
Old 05-25-2018, 06:35 PM
Registered User
 
Join Date: Oct 2015
Posts: 134
76 280c wiring

Quote:
Originally Posted by Idle View Post
Anyone have a wiring diagram they can post?

And... Are there any other electrical items that are not working on this car?
yes I have Mercedes wiring diagram . 1975 to 1979 Mercedes electrical troubleshooting manual . aux fan fuse box mounted on left fender have 3 wires hanging off a broken fuse box f 20 off batt bus theres a 2.5 rd/b k wire going to fuse fuse box then theres a rd/ bu 2.5 wire leaving fuse box to 3 #30 on aux fan relay my aux fan doesn't work on my 76 280 c aux fuse box theres a red and a blu and a larger red attached to main fuse attached a test light says power even with key off in diagram manual I only see aux fan fuse box with only 2 wires wonder what yr vechile looks like with relay on lrft fender in engine compartment behind the main fuse panel see no main fuse panel in this manual if you need any diagrams ill post they are larger versions ill upload pics too
Reply With Quote
  #7  
Old 05-25-2018, 06:53 PM
Registered User
 
Join Date: Oct 2015
Posts: 134
Quote:
Originally Posted by Idle View Post
Anyone have a wiring diagram they can post?

And... Are there any other electrical items that are not working on this car?
aux fan power windows
Reply With Quote
  #8  
Old 05-25-2018, 09:14 PM
Registered User
 
Join Date: Oct 2015
Posts: 134
power windows and aux fan wiring

Quote:
Originally Posted by Idle View Post
Anyone have a wiring diagram they can post?

And... Are there any other electrical items that are not working on this car?
aux fan doesn't work and no power to windows . tried to pst picture wouldn't upload . ill explain . on left fender side . in engine compartment. behind main fuse box . theres this f20 fusebox . in diagram posted . says rd bk wire runs fr batt bus . into fuse box 20 . then theres another rd / bu wire that leads off fuse box to #30 aux fan relay . on my 76 280 c theres a red wire hot all times running fr main fusebox and this black wire and a blue wire coming from firewall where the vacuum lines run into a grommet noticed the blue wire runs under the rocker panel moulding need to remove the rear seats to locate not sure if the blue and black wires are correct in subsistute what the diagram says . since see no fuse panel the main one in this Mercedes electrical troubleshooting manual . figured maybe someone has a simuliar model and could write notes or send a picture . not easy reading some diagrams confused
Attached Thumbnails
1976   280c  no power to powerwindows-img_0979.jpg   1976   280c  no power to powerwindows-img_0980.jpg  
Reply With Quote
  #9  
Old 05-26-2018, 07:23 AM
ejboyd5's Avatar
Registered User
 
Join Date: Aug 2004
Location: Southold, NY
Posts: 230
Quote:
Originally Posted by huffandpuff View Post
not easy reading some diagrams confused
You are not the only one who is "confused." Your writing "style" doesn't help those who might want to help you. Please remember, capitalization and punctuation are our friends.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page