Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-02-2019, 05:07 PM
Registered User
 
Join Date: Nov 2018
Posts: 28
Airconditioner evaporator drain sluge w115

My AC evaporator on my 1976 240 D w115 keeps getting plugged with black slime at yhe drain where it conects to the drain hose. Any solutions or advice? Thanks.
Reply With Quote
  #2  
Old 07-04-2019, 10:52 PM
Registered User
 
Join Date: Nov 2018
Posts: 28
I was able to fix the problem. I took off the air intake grill covers and sprayed lemon lysol into the fan while running. I let it sit overnight and no more problems. My drain runs great now.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page