Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-10-2019, 07:39 PM
Registered User
 
Join Date: Feb 2003
Location: Oklahoma
Posts: 1,028
'72 250 fuel pump concern

Haven't been around here for a while - car has been running ok until just the past week. Was having some vacuum leak problems and I replaced one of my climate control vacuum pods under the dash...

Car was having trouble idling, without keeping the gas pedal pressed. Now the car won't start - cranks fine but no start. Pulled the fuel supply lines from the Zenith carbs and cranked - no gas. Pulled the filter from the Pierburg mechanical pump and no gas...

I replaced the pump many years ago - do they just go bad? Any other reason I might not be getting fuel to the carbs?

ryan
__________________
RG Newell

1984 300D
1972 250
1986 560SL
1991 300CE
Reply With Quote
  #2  
Old 10-10-2019, 08:25 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,850
Quote:
Originally Posted by rgnprof View Post
Pulled the fuel supply lines from the Zenith carbs and cranked - no gas. Pulled the filter from the Pierburg mechanical pump and no gas...
I replaced the pump many years ago - do they just go bad? Any other reason I might not be getting fuel to the carbs?

1) Tank is empty.

2) Flex line between chassis & pump has a hole; sucking air.

3) Line between tank & flex line is clogged.

4) Screen in tank is clogged.

5) Pump has failed [which may or may not be why you replaced the pump many years ago!]
Reply With Quote
  #3  
Old 10-11-2019, 08:51 AM
Registered User
 
Join Date: Feb 2003
Location: Oklahoma
Posts: 1,028
Thanks for the reply!

Tank is not empty and I'm pretty sure the pump was bad when I replaced it 15 years ago as the car ran fine after a new pump.

Not sure about 2, 3 and 4...I've probably got 10 gallons in the tank right now so I'm not sure how to go about draining that much fuel to check on the screen...I'll just have to crawl under and look for issues 2 & 3...
__________________
RG Newell

1984 300D
1972 250
1986 560SL
1991 300CE
Reply With Quote
  #4  
Old 10-11-2019, 03:03 PM
meltedpanda's Avatar
Certified Benzaholic
 
Join Date: Mar 2003
Location: Central Ky
Posts: 6,133
Id second the screen pull line from tank before pump. See what flow you get. Wear safety gear be ready to place back on. After determination is made
Reply With Quote
  #5  
Old 10-12-2019, 06:44 PM
Registered User
 
Join Date: Feb 2003
Location: Oklahoma
Posts: 1,028
Installed a brand new Meyle fuel pump and it made no difference - do I have to prime this new pump somehow???...would like to pull the strainer in bottom of tank but have to figure out a way to drain the gas.

I have checked the lines as best I could - just eyeballing them...don't see anything obvious.
__________________
RG Newell

1984 300D
1972 250
1986 560SL
1991 300CE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page