Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2020, 08:23 PM
j-galap's Avatar
Strich Acht
 
Join Date: Aug 2018
Location: Istanbul / Vancouver
Posts: 261
Defogging problems - 1974 W115 240D

Hi folks,

I'm having a couple of defogging issues with my 240D.

1. The rear heated screen works well to begin with (using the pull switch on the centre console) but if you need to use it more than a couple of times it turns off almost immediately. What would be the problem here?

2. The interior fan switch is a little temperamental. Initially, it works well, but after driving for a while with the fan on it will stop. I've realized that if I hold the switch not at 'resting' (as in: just before it flicks on to the next setting) the fan comes back on. I'm sure it's an issue with the switch, not the fan. Any ideas?

Any help with this would be greatly appreciate

Cheers

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page