Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Vintage Mercedes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2005, 10:49 PM
Registered User
 
Join Date: Nov 2005
Posts: 5
1988 300e

it seems as if my transmission is sticking pretty bad. it will not go over 40mph and has an awful winding noise when I try to accellerate. there is a leak from the seals..its leaking on the exhaust and giving off an awful maybe toxic fumes. is it possible from the leaky seals that my transmission is in the process of slipping? yes, I do keep enough fluid in there its never been under 2 pints.
Reply With Quote
  #2  
Old 11-28-2005, 11:40 PM
Registered User
 
Join Date: Aug 2004
Posts: 72
1988 300e

I am puzzled by your reference to 2 pints.
The capacity is about 6.5 pints as I recall??
You should make sure it is full.
When cold and the engine running it should be about 10 mm below the add mark.

Doug Quance
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page