Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Vintage Mercedes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-20-2017, 01:20 PM
Registered User
 
Join Date: Jul 2014
Posts: 65
Looking at a 78 w116 280SE Sat...

Hey Folks,

I'm looking at and planning to take home a 78 280SE sat with an M110..

the selling told me that the motor starts and then stalls.. I know this isn't much to go off of but I'm wondering if anyone has an idea of why it might do this?

I would like to buy it.. fix it/ macgyver it immediately, then drive it home.

I'm pretty used to diesels where quick simples fixes are usually possible but am not used to the big fuel injected straight sixes.

any thoughts would be appreciated. I may bring some extra fuel line and filters.
Reply With Quote
  #2  
Old 04-20-2017, 03:52 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,145
1) How long has it been since the car was last run. If more than a year, there may be cause to suspect some clogging in the small orifices of the injection system.

2) Does the engine stall immediately after releasing the key from the "start" position and returning it to the "run" position, or, does the engine run for a couple of seconds after the key is released from "start"?
If there is an immediate stall, the cause may be ignition related. There may be a faulty resistor in the primary circuit, or there may be a defective key switch.
If there is a short period of running, the problem is likely in the injection. Having an ignition fault while trying to find an injection problem is likely to make you feel like Sisyphus.
Reply With Quote
  #3  
Old 04-22-2017, 07:59 PM
Registered User
 
Join Date: Jul 2014
Posts: 65
Quote:
Originally Posted by Frank Reiner View Post
1) How long has it been since the car was last run. If more than a year, there may be cause to suspect some clogging in the small orifices of the injection system.

Seller says it has started and run for brief periods of time but I suspect at most 10 years since the last inspection sticker reads 2006

2) Does the engine stall immediately after releasing the key from the "start" position and returning it to the "run" position, or, does the engine run for a couple of seconds after the key is released from "start"?

I believe it starts for a second after releasing the key, I however was under the hood while the seller was trying to start it

If there is an immediate stall, the cause may be ignition related. There may be a faulty resistor in the primary circuit, or there may be a defective key switch.
If there is a short period of running, the problem is likely in the injection. Having an ignition fault while trying to find an injection problem is likely to make you feel like Sisyphus.
The seller told me it has run for varying periods of time, i guess anywhere from 2 seconds to almost a miniute
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page