Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Vintage Mercedes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-11-2018, 08:24 AM
Registered User
 
Join Date: Oct 2015
Posts: 82
rt fog light

fog light bulb goes on and off had lens cover off bulb was on then put all together no light on rt side just left side works any ideas ??
Reply With Quote
  #2  
Old 04-11-2018, 03:15 PM
ejboyd5's Avatar
Registered User
 
Join Date: Aug 2004
Location: Southold, NY
Posts: 219
If the lamp illuminated intermittently, it would appear that you have electricity flowing sometimes which probably rules out a bad fuse or bad connection upstream from the lamp. I would take the light apart, clean all the contacts, particularly the connection between the light and the car which provides a ground for the circuit. You can save yourself a fair amount of time by using a multimeter or a test light to check for continuity before stripping everything apart. Try simple things first; perhaps the lamp itself is bad.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page